Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 17
Number of dependencies (NOD): 106
Number of unique artifacts (NOA): 112
Number of version-conflicting artifacts (NOC): 4
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 94 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

com.google.guava:guava

[Error]
16.0.1
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.5.2:provided
       \- com.google.inject:guice:jar:no_aop:4.0:provided
          \- (com.google.guava:guava:jar:16.0.1:provided - omitted for conflict with 20.0)

20.0
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.5.2:provided
       +- org.apache.maven:maven-model-builder:jar:3.5.2:provided
       |  \- (com.google.guava:guava:jar:20.0:provided - omitted for duplicate)
       +- org.apache.maven:maven-resolver-provider:jar:3.5.2:provided
       |  \- (com.google.guava:guava:jar:20.0:provided - omitted for duplicate)
       \- com.google.guava:guava:jar:20.0:provided

org.apache.maven:maven-artifact

[Error]
3.0
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.5.1:provided
       \- org.apache.maven:maven-artifact:jar:3.0:provided

3.5.2
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-plugin-api:jar:3.5.2:provided
    |  \- (org.apache.maven:maven-artifact:jar:3.5.2:provided - omitted for conflict with 3.0)
    \- org.apache.maven:maven-core:jar:3.5.2:provided
       +- (org.apache.maven:maven-artifact:jar:3.5.2:provided - omitted for conflict with 3.0)
       \- org.apache.maven:maven-model-builder:jar:3.5.2:provided
          \- (org.apache.maven:maven-artifact:jar:3.5.2:provided - omitted for conflict with 3.0)

org.codehaus.plexus:plexus-component-annotations

[Error]
1.5.5
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-plugin-api:jar:3.5.2:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.3:provided
          \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:provided - omitted for conflict with 1.7.1)

1.7.1
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.5.2:provided
       +- org.apache.maven:maven-settings-builder:jar:3.5.2:provided
       |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.7.1:provided - omitted for conflict with 1.5.5)
       +- org.apache.maven:maven-model-builder:jar:3.5.2:provided
       |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.7.1:provided - omitted for conflict with 1.5.5)
       \- org.codehaus.plexus:plexus-component-annotations:jar:1.7.1:provided

org.codehaus.plexus:plexus-utils

[Error]
1.5.5
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.5.2:provided
       \- org.apache.maven:maven-settings-builder:jar:3.5.2:provided
          \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.4:provided
             \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:provided - omitted for conflict with 3.1.0)

2.0.4
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.5.1:provided
       \- org.apache.maven:maven-artifact:jar:3.0:provided
          \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:provided - omitted for conflict with 3.1.0)

3.0.17
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-plugin-api:jar:3.5.2:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.3:provided
          \- (org.codehaus.plexus:plexus-utils:jar:3.0.17:provided - omitted for conflict with 2.0.4)

3.1.0
  1. net.truelicense:truelicense-maven-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-plugin-api:jar:3.5.2:provided
    |  +- org.apache.maven:maven-model:jar:3.5.2:provided
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.1.0:provided - omitted for conflict with 2.0.4)
    |  \- org.codehaus.plexus:plexus-utils:jar:3.1.0:provided
    \- org.apache.maven:maven-core:jar:3.5.2:provided
       +- org.apache.maven:maven-settings:jar:3.5.2:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.1.0:provided - omitted for duplicate)
       +- org.apache.maven:maven-settings-builder:jar:3.5.2:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.1.0:provided - omitted for duplicate)
       +- org.apache.maven:maven-repository-metadata:jar:3.5.2:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.1.0:provided - omitted for duplicate)
       +- org.apache.maven:maven-model-builder:jar:3.5.2:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.1.0:provided - omitted for duplicate)
       +- org.apache.maven:maven-resolver-provider:jar:3.5.2:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.1.0:provided - omitted for duplicate)
       \- (org.codehaus.plexus:plexus-utils:jar:3.1.0:provided - omitted for duplicate)